OpenWrt 下 升级PassWall 使用 hysteria2

网络资源 admin 来源:augustdoit 2个月前 (03-30) 183次浏览 0个评论

更新 PassWall

版本介绍

sing-box 自 1.5.0-beta.2 后支持 Hysteria 2。

PassWall 最新的版本 4.71-2支持 sing-box 1.53。

PassWall 4.71-2基于 OpenWrt23.05-rc3 构建,如果你的 OpenWrt 版本不是很低,且不想升级或重刷 OpenWrt的固件的情况下使用Hysteria2, 那请看这篇教程。

建议提前做好备份,博主 Openwrt 版本 21.02 没有问题。如果版本太低会带来不可预知的依赖问题。

检查现有 passwall 是否支持 hysteria2

是否含 Hysteria 2 及 sing-box。

下载最新 passwall 及组件包

openwrt-passwall 最新发布页

依赖包 luci-lua-runtime

依赖包本站备份

  • 软件包 luci-app-passwall_4.71-2_all.ipk
  • 中文包 luci-i18n-passwall-zh-cn_git-23.289.45328-a953315_all.ipk
  • 对应CPU构架的组件包 passwall_packages_ipk_x86_64 注意构架
  • 依赖包 luci-lua-runtime Openwrt 23.05-rc3 以下版本需要

查询软路由CPU构架

SSH 连接软路由,输入如下命令

uname -m

例如我的输出 x86_64

安装

# 进入安装包所在目录
cd /tmp/upload
# 查看目录下所有文件
ls
# 解压安装包
unzip luci-lua-runtime_all_fake.zip
unzip passwall_packages_ipk_x86_64.zip
# 清屏
clear
# 查看目录下所有文件
ls
# 安装所有软件包
opkg install *.ipk --force-reinstall

输出提示 sing-box没有安装上,没有关系,我们回到网页 Passwall 更新组件即可。

添加 Hysteria2 节点

参照视频即可


VPS小白 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:OpenWrt 下 升级PassWall 使用 hysteria2
喜欢 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址